Comment on Introducing e-Mandates – Now fund your SIPs automatically

Matti commented on 14 Oct 2019, 05:07 PM

You’ll need an account with a bank that supports UPI 2.0 or wait for your bank to be enabled on this.

View the full comment thread »