Comment on Introducing the Kite 3 mobile app

sudakaran commented on 02 Jul 2019, 10:33 PM

It says your device is not compatible with this app. Please list the Andriod device minimum requirement. I have Redmi phone with Kit-Kat version of android. Will it support Kite 3.0 Mobile.

View the full comment thread »